Identification processing delays
Incident Report for Ubble
Resolved
A fix has been implemented and the issue is now resolved.
Posted Aug 18, 2022 - 11:19 UTC
Investigating
We are experiencing issues for processing identifications
Posted Aug 18, 2022 - 10:43 UTC
This incident affected: IDApp.