Verification Processing Delays

Incident Report for Checkout Identity Verification

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 17:19 UTC

Investigating

Our identity verification backlog is increasing due to an issue, we are investigating the root cause. We might miss some identity verification SLA's.
Posted Sep 01, 2026 - 17:09 UTC
This incident affected: IDApp and API.