Increased latency

Incident Report for Checkout Identity Verification

Resolved

This incident has been resolved.
Posted Sep 02, 2026 - 15:04 UTC

Identified

We are seeing degraded performance on our API due to an issue with our caching layer. Issues have been fixed but the cache needs to re-warm which will take some time. Calls to our api will be slower and might timeout sporadically.
Posted Sep 02, 2026 - 13:56 UTC
This incident affected: API.