Identity Verification Processing delays
Incident Report for Ubble
Resolved
This incident has been resolved.
Posted Oct 13, 2023 - 07:52 UTC
Identified
Due to a combination of technical difficulties affecting our operators productivity and an unexpected rise in our inflow volumes, identifications received from yesterday 20h (11-10-2023. 20h00 Paris time) until today may take longer to be processed. The situation is under control and expected to be resolved by the end of the day.
Posted Oct 12, 2023 - 10:11 UTC
This incident affected: IDApp.