Verification Processing Delays
Incident Report for Ubble
Resolved
Situation is back to normal since early this morning. Closing the incident.
Posted Apr 27, 2024 - 08:36 UTC
Monitoring
The situation is now under control and no SLAs are missed anymore. We will keep monitoring the backlog closely until tomorrow.
Posted Apr 26, 2024 - 20:04 UTC
Identified
Due to some unexpected workload we are missing some SLAs on the Certified offer, we are doing our best to catch up with the backlog.
Posted Apr 26, 2024 - 17:01 UTC
Investigating
Our identity verification backlog exceeds our current capacity and we are missing some SLAs. We are doing our best to catch up and get back to normal as soon as possible.
Posted Apr 26, 2024 - 16:48 UTC
This incident affected: IDApp.