Identification Processing Delays
Incident Report for Ubble
Resolved
This incident has been resolved.
There are still some certified identity verifications in our backlog but we are catching up.
Furthermore we continue working on temporary mitigation solutions to prevent this incident from happening in the future.
Posted Nov 16, 2023 - 08:33 UTC
Update
Object storage looks stable enough and we are able to go through our backlog. We're still actively monitoring the situation to avoid any additional impact and will resolve the incident if we see the situation staying like this through the day. We're still actively working on alternative solutions that can be temporary activated if needed.

Thank you for your understanding.
Posted Nov 15, 2023 - 08:59 UTC
Monitoring
Our cloud provider has mitigated the issue, the situation seems stable for now, we will keep monitoring throughout the night.
On our side we are starting to treat the backlog that was created by the incident so there will still be delays in identity verification processing.
Posted Nov 14, 2023 - 18:48 UTC
Update
Our cloud provider object storage for our certified product won't be back up before end of day.

We are working hard on alternative temporary solutions to be able to process certified inflow. We expect to have a solution in a few hours, we will provide a new update in 1 hour.

The backlog created today will need to wait for the recovery of our cloud provider to be processed.
Posted Nov 14, 2023 - 18:19 UTC
Update
Our cloud provider has is still not communicated a resolution ETA.
So we started the work on developing mitigation solutions to by pass the use of our cloud provider storage solution temporarily for the certified.
We will keep you updated.
Posted Nov 14, 2023 - 16:18 UTC
Update
We have implemented a quickfix on our side, the user flow conversion is back to normal. So users performing their identity verification for the certified offer are no longer impacted.
However, the identity verification process is still running behind as our operators cannot verify certified id's due to our cloud provider storage solution outage.
We will keep you posted.
Posted Nov 14, 2023 - 14:58 UTC
Update
Our cloud provider is still actively working on the issue, we have no news for now.
Posted Nov 14, 2023 - 14:26 UTC
Update
Our cloud provider has mitigated part of the issue, the service is a little more stable, but the issues are still there. We will continue to keep you posted.
Posted Nov 14, 2023 - 13:10 UTC
Update
Our cloud provider is still investigating the issue.
We are currently working on a quick fix to resolve the impact on the user flow so that conversion is not impacted anymore for certified identity verifications.
Posted Nov 14, 2023 - 12:23 UTC
Update
Only the certified identity verifications are impacted, user will have difficulties performing their identity verifications and our operators will be unable to perform the verifications.
Posted Nov 14, 2023 - 11:40 UTC
Update
Our cloud provider has identified the issue and is working on a fix.
Posted Nov 14, 2023 - 11:27 UTC
Identified
The issue has been identified.
Posted Nov 14, 2023 - 11:18 UTC
Investigating
Our data processing infrastructure is running behind which is causing delays in our ID verifications. No data has been lost and we're investigating the root cause. The certified flow is impacted as our cloud provider certified object storage is unavailable.
We have notified them and are waiting for a response.
Posted Nov 14, 2023 - 11:16 UTC
This incident affected: API, Dashboard, and IDApp.