Verification Processing Delays
Incident Report for Ubble
Resolved
This incident has been resolved.
Posted Apr 12, 2024 - 12:21 UTC
Monitoring
Problem is related to office network issues. It is now mitigated and backlog is starting reduce from now.
Posted Apr 12, 2024 - 11:35 UTC
Identified
Our identity verification backlog exceeds our current capacity and we are missing some SLAs. We are doing our best to catch up and get back to normal as soon as possible.
Posted Apr 12, 2024 - 11:03 UTC
This incident affected: API.