Verification Processing Delays
Incident Report for Ubble
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 15:52 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2024 - 15:34 UTC
Identified
Our identity verification backlog exceeds our current capacity and we are missing some SLAs. We are doing our best to catch up and get back to normal as soon as possible.
Posted Mar 26, 2024 - 15:18 UTC
This incident affected: IDApp.