Identification Processing Delays
Incident Report for Ubble
Resolved
This incident has been resolved.
Posted Aug 29, 2023 - 14:30 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 29, 2023 - 13:44 UTC
Investigating
Our data processing infrastructure is running behind which is causing delays in our ID verifications. No data has been lost and we're investigating the root cause.
Posted Aug 29, 2023 - 12:48 UTC
This incident affected: API and Dashboard.